Anúncios
Início > Endian, Infra, Segurança > Tutorial: Habilitando Endian para autenticar usuários no AD

Tutorial: Habilitando Endian para autenticar usuários no AD


Olá a todos

Segue um novo tutorial que mostra como habilitar o Endian Firewall para autenticar os usuários no AD.

Para fazer isso devemos em primeiro lugar ir em “Network/Edit Hosts/Add a host”

Será exibida tela semelhante a abaixo.

Coloque o IP Address do seu Domain Controller, em Hostname coloque o nome do servidor e em Domain Name o nome do seu domínio.

Ex. IP192.168.0.10/Hostname DC1/Domain domain.local

Em seguida navegue até “Proxy/Authentication” em “Choose Authentication Method” selecione Windows Active Directory (NTLM).

Preencha as informações abaixo lembrando obviamente de por as informações relativas ao seu domínio, neste caso vamos seguir o exemplo já citado.

Feito isso clique em SAVE e depois clique no Botão “Join domain” onde você deve colocar seu usuário senha de administrador do domínio.

Se tudo estiver correto você vai receber  uma mensagem dizendo que você ingressou ao domínio com sucesso.

Agora para fazer com que o endian exiga a autenticação dos usuários basta ir em “Proxy/Access Policy” em authentication você pode habilitar por exemplo “group based” e escolher qual grupo pode acessar internet, para o nosso exemplo vamos liberar acesso ao grupo “domain users” vai ficar assim:

Clique em “Create Policy”

Agora é só testar. As estações precisam estar com o proxy habilitado no IE, como estamos falando de um ambiente com AD podemos fazer isso via GPO sem precisar configurar manualmente todas estações.

Espero ter ajudado e até a próxima. Dúvidas deixe seu comentário aí em baixo.

Anúncios
Categorias:Endian, Infra, Segurança Tags:, ,
  1. Ederson
    06/01/2011 às 10:05

    Ola amigo vc conseguiu no windows 2008 fazer essa autenticação?
    Obrigado

    • 06/01/2011 às 10:07

      Olá Ederson

      Ainda não testei em 2008 mas não creio que terá grandes dificuldades qto a isso.

    • Ederson
      06/01/2011 às 13:53

      Entao estou fazenod um teste com a versão 2.3 e funcinou pelomenos a autenticação
      vou fazer teste com as regras

  2. Caio
    20/01/2011 às 16:30

    Olá,
    Estou usando a versão do Endian 2.4.1, e não consigo fazer a integração com o AD.
    Quando coloco o Proxy no Navegador do Usuário, ao entrarmos em qualquer página pede a autenticação do Proxy.
    Digitamos o Usuário e a Senha e fica dando Looping essa autenticação e não funciona.

    Meu AD é um Windows 2008 Standard R2

    Podem me ajudar ?

    Obrigado!

    • Fabiano
      24/02/2011 às 11:50

      Opa Caio! Tive o mesmo problema aqui, o que acontece é que há um BUG na versão do samba com o Windows 2008 R2, se voce verificar no log do samba vai ver o erro fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED é preciso atualizar a versão do samba para que funcione … abs

    • 02/03/2011 às 14:00

      Olá Caio tem um feedback novo no blog sobre isso dá uma olhada lá e ve se pode ajudar

      Abraço

  3. Marvin
    25/01/2011 às 9:24

    …nesse caso, podemos usar com o proxy transparente ?

    • 25/01/2011 às 11:43

      Não, precisa selecionar autenticação no AD para validar os usuários, mas a autenticação é feita usando o usuário que já está autenticado, ou seja, não vai pedir usuário e senha.

  4. Jeremias Oliveira
    09/02/2011 às 12:50

    Bom dia Hernane, segui todas etapas do seu tutorial e conseguir autenticação pelo endian, mais ainda não estou conseguindo usar os usuarios do AD para acessar a intenet.

    Meu AD utiliza o ip com final .1 meu endian utiliza o ip com final 252, quando eu vou configurar o proxy no IE, eu coloco o IP do Endian, correto ? e a porta utilizada pelo proxy no caso a 8080, quando faço isso ele fica pedindo usuario e senha do dominio e coloco os usuarios da rede e nao tem resultado, o que pode esta aconteçendo ? o proxy tem que esta em modo Transparente ou nao transparente ? ja tentei das 2 formas e aconte a mesma coisa, o que poderia esta acontecendo? Desde já agradeço.

    Jeremias Oliveira

    Adm. de Redes

    • 02/03/2011 às 14:00

      Olá Jeremias tem um feedback novo no blog sobre isso dá uma olhada lá e ve se pode ajudar

      Abraço

  5. Marvin
    25/02/2011 às 15:33

    Comigo estava acontecendo o mesmo que acontece com o Jeremias …

    … estou logado com uma conta do domínio, ou seja, já estou autenticado … não faz sentido pedir usuário e senha novamente … tento colocar até o “Administrador” e “senha do ADministrador do AD” … mas tambem sem sucesso …

    na conexão local ativo o proxy para “ip.do.servidor” porta “8080” … o proxy tranparente bloqueia tudo e o não transparente só conecta com https ( << isso é importante )

    alguma configuração no firewall do endian ?? firewall do host e do server onde esta o AD estão desabilitados pra fazer os testes ..

    ajuda ? Valeu…

    Server 2008

  6. 01/03/2011 às 9:07

    Bom dia venho ate aqui pra agradecer pelo tutorial pois venho tentando integrar o endian ao ad a muito tempo, e agora que vi o seu bem explicado conseguir,

    o progrema do meu era no autentication que não estava colocando no autentication realm eu tava deixando proxy ai não estava pegando.

    ai coloquei o dominio e pronto quando coloquei o nome e senha no adjoin pronto adicionado com o ad com sucesso

    eba que beleza valeu mesmo obrigado.

  7. 01/03/2011 às 9:22

    Marconi :

    Bom dia venho ate aqui pra agradecer pelo tutorial pois venho tentando integrar o endian ao ad a muito tempo, e agora que vi o seu bem explicado conseguir,

    o progrema do meu era no autentication que não estava colocando no autentication realm eu tava deixando proxy ai não estava pegando.

    ai coloquei o dominio e pronto quando coloquei o nome e senha no adjoin pronto adicionado com o ad com sucesso

    eba que beleza valeu mesmo obrigado.

    Olá Marconi, fico feliz que tenha conseguido e pelo comentário

    Abraço

  8. Jeremias
    01/03/2011 às 9:42

    Olá Hernane, e sobre meu problema, vc tem alguma ideia, eu autentico e tudo consigo ver os grupos mais ele continua pedindo usuario e senha e mesmo colocando ele nao vai, se possivel me add no msn, vc me ajudaria muito me tirando esta duvida, loganinformatica@gmail.com , este é meu msn, um abraço, todos que puderem me ajudar favor me add no msn. Obrigado a todos.

  9. Marvin
    01/03/2011 às 9:49

    … desde que voltem aqui pra dizer como foi solucionado, já ouvi dizer que era problema no SAMBA, até segui um tuto dizendo como faria pra contornar, mas até agora nada feito … tambem diziam que o problema era acessando com windows 7 (não tentei com XP) que devia mudar algum valor no registro, tambem tentei mas nada feito …

    ta complicado …

    Hernane, tem outra forma de aplicar politica diferenciada pra grupos diferenciados no Endian ??seria de grande ajuda um tuto sobre esse assunto …

    Abraço povo, Sorte !

    • 01/03/2011 às 9:52

      Olá

      Estou fazendo uns testes aqui e assim que descobrir algo que possa ajudar vou postar no blog

      Abraço a todos.

    • 02/03/2011 às 13:59

      Olá tem um feedback novo no blog sobre isso dá uma olhada lá e ve se pode ajudar

      Abraço

  10. Mailson Mota
    13/05/2011 às 18:26

    Caro colega parabens pelo site, estou iniciando com o endian realizando testes em uma rede virtual com o endian 2.4.1, uma máquina xp SP3 e um servidor wind. 2003 com controlador de dominio mas não consigo autenticar o endian no dominio, já pesquisei em vários foruns e todas as dicas já apliquei mas continuo ainda sem autenticar no AD. Já editei o arquivo “etc/samba/winbind/conf.tmpl” e nada. Vou colocar como estou fazendo:
    1 – Na aba <>> estou adicionado os dados do servidor:
    IP=192.168.0.254
    NOME=servidorsistema
    NOME DOMINIO=saae.com.br
    2 – Na aba <><><> Selecionado<>(Já tentei também utilizando transparente e não consegui)
    3 – Na aba <><><> Estou deixando da seguinte maneira:
    Choose Authentication Method * = Windows Active Directory (NTLM)
    Authentication Realm=saae.com.br
    Number of Authentication Children=20
    Authentication cache TTL (in minutes)=20
    Number of different ips per user * = 0
    User / IP cache TTL (in minutes) * = 0
    Domainname of AD server=saae.com.br
    PDC hostname of AD server=servidorsistema
    PDC ip address of AD server=192.168.0.254

    – Na hora de colocar o meu usuário adminstrador e a senha do domino na aba <> me apresenta o seguinte erro “FAILED TO JOIN DOMAIN”

    Gostaria de saber se preciso fazer alguma coisa no meu dominio(WindowsServer2003)pra que funcione, já que eu acho que as configurações que estou utilizando no endian estão corretas? Preciso muito de sua. Desde já agradeço.

  11. Mailson Mota
    14/05/2011 às 0:48

    Hernane parabens pelo site cheio de tutorias bacanas, estou iniciando com o endian realizando testes em uma rede virtual com o endian 2.4.1(servidor dhcp), uma máquina xp SP3 e um servidor wind. 2003 com controlador de dominio mas não consigo autenticar o endian no dominio, já pesquisei em vários foruns segui o seu passo-a-passo mas continuo ainda sem autenticar no AD. Já editei o arquivo “etc/samba/winbind/conf.tmpl” e nada. Vou colocar como estou fazendo:
    1 – Na aba <>> estou adicionado os dados do servidor:
    IP=192.168.0.254
    NOME=servidorsistema
    NOME DOMINIO=saae.com.br
    2 – Na aba <><><> Selecionado<>(Já tentei também utilizando transparente e não consegui)
    3 – Na aba <><><> Estou deixando da seguinte maneira:
    Choose Authentication Method * = Windows Active Directory (NTLM)
    Authentication Realm=saae.com.br
    Number of Authentication Children=20
    Authentication cache TTL (in minutes)=20
    Number of different ips per user * = 0
    User / IP cache TTL (in minutes) * = 0
    Domainname of AD server=saae.com.br
    PDC hostname of AD server=servidorsistema
    PDC ip address of AD server=192.168.0.254

    – Na hora de colocar o meu usuário adminstrador e a senha do domino na aba <> me apresenta o seguinte erro “FAILED TO JOIN DOMAIN”

    Gostaria de saber se preciso fazer alguma coisa no meu dominio(WindowsServer2003)pra que funcione, já que eu acho que as configurações que estou utilizando no endian estão corretas? Desde já agradeço.

  12. 16/05/2011 às 10:08

    Olá,

    Seu ad e DNS está funcional? vc consegue colocar a estação windows XP como membro do domínio? se você for na console do endian e digitar “ping saae.com.br” ele deve ser capaz de responder ao ping resolvendo o IP do DC, se não pingar certamente vc vai precisar rever suas configurações no Endian, usando o tutorial, ou verficar a funcionalidade do seu domínio.

    Abraço

    • Mailson Mota
      16/05/2011 às 15:47

      Hernane, minha máquina xp tá no dominio e o endian consegue pingar o meu servidor wind. server2003 pelo endereço IP. Vou refazer as configuração e te informo. Muito obrigado pela atenção.

  13. Claudio
    01/06/2011 às 0:37

    Tem como funcionar Proxy Transparente com Autenticação ?

    Grato

    Cláudio Bruno

  14. Alan
    08/09/2011 às 7:12

    Ederson :
    Ola amigo vc conseguiu no windows 2008 fazer essa autenticação?
    Obrigado

    Amigo eu conseguir roda no windows 2008 r2
    vc segue o mesmo passo desse tutorial, e no AD >Computador, vai apareder o Computador do Firewall com endian instalado, depois vc delegar permição a esse computador e logo seguida e so testar o Join Domain.

    No meu aqui esta funcionando 100%

  15. GlaucoThiele
    21/10/2011 às 15:56

    Que delegação tem que habilitar no AD 2008 R2 para parar esse loop de autenticação??

  16. Diego
    28/11/2011 às 12:34

    O meu sempre aparece a msg

    Failed to join domain: failed to find DC for domain DIVIMED

    O que eu faco?

    • 28/11/2011 às 12:53

      Qual o nome do seu domínio? Qual o nome do seu DC?
      Manda um print da tela de como vc está configurando o Endian!

  17. Diego
    28/11/2011 às 12:43

    agora aparece

    Failed to join domain: Invalid configuration (“workgroup” set to ‘CORP’, should be ‘DIVIMED’) and configuration modification was not requested

  18. Diego
    01/12/2011 às 17:53

    Segue a mesma, sou novo na aera fiz muita coisa que li via SSh
    mas nada funcionou sempre da erro descritos acima.

    http://imageshack.us/photo/my-images/85/blogyu.jpg/

    • 02/12/2011 às 9:35

      Diego :

      Segue a mesma, sou novo na aera fiz muita coisa que li via SSh
      mas nada funcionou sempre da erro descritos acima.

      http://imageshack.us/photo/my-images/85/blogyu.jpg/

      Olá Diego

      Vamos lá,
      Servidor, é o hostname correto do seu controlador de domínio? Vc tem mais de um controlador de domínio?
      Pelo endian vc consegue pingar usando o hostname do servidor? você consegue pingar o nome do domínio corp.divimed?

      • Diego
        02/12/2011 às 13:52

        Consigo, pingo normalmente tanto pelo ip qto pelo hostname…
        Nao sei, ao exato mas acredito que seja alguma coisa que eu fiz ou deixei de fazer…

      • diego
        06/12/2011 às 13:05

        Alguma ideia hernane?

  19. Diego
    01/12/2011 às 19:07

    Ate peco desculpas ,mas se tiver um passo a passo eu agradeco.
    Tenho que fazer alguma configuracao inicial antes de ir pro proxy autenticacao?
    Obrigado.
    Estou o dia intiero brigando com isso e nao cosnigo fazer a comunicacao com o AD
    Estou usando bloqueio por IP comas regras mas queria com o AD para fazer pro grupo de usaurios..

  20. Diego
    11/04/2012 às 16:37

    11/04 e o problema continu

  21. Thiago Alexandre
    12/04/2012 às 15:26

    Professor

    Quando tento entrar ele aparece esse erro: falha ao ingressar dominio: não conseguiu encontrar DC para o dominio “X”

    • 13/04/2012 às 18:27

      Na console do endian digite Ping nomedodomio o endian deve ser capaz de resolver esse nome caso isso não aconteça verifique as configurações do dns

  22. Paulo Ricardo
    24/04/2012 às 15:12

    Como faço para saber qual a versão do samba no meu endian?

  23. Anderson
    10/12/2012 às 11:10

    Creio que no 2008 não funcione, pois já utilizei o usuario administrador, e até criei outros usuarios com poderes administrativos e nada .
    Dominio funcionando 100% , pingando no Endian ok.

    • 12/12/2012 às 18:37

      Olá Anderson, o meu funciona em 2008, o seu DC é o único da rede?

  24. andreazza
    27/12/2012 às 3:15

    fiz todos os passos mas nao deu certo tambem..
    montei um lab virtual com Endian 2.5.1 (nome: firewall.asti.com – ip 10.1.1.1)… win2008r2 (nome: dc1.asti.com – ip 10.1.1.10) …winXP (dhcp)…
    cadastrei o host dc1 dominio asti.com e ip 10.1.1.10…
    de dentro do ssh: ping asti.com ele resolve ok e pinga ok
    no realm coloquei asti.com
    e logo abaixo tambem tudo ok.. já revisei ortografia 3 vezes… mas tudo está ok….
    quando dou um join ads, ele diz que nao consegue resolver DC pro ASTI.COM….
    tentei desativar firewall do windows. mas nada tambem..

    tambem tentei cadastrar um registro de direcionamento DNS mas nao fez diferença..
    mais alguem com alguma ideia?? ou que tenha passado por isso e funcionado…

    obrigado desde já!

  25. andreazza
    03/01/2013 às 14:01

    estranho… depois de reiniciar varias vezes o endian.. funcionou! hehehe
    vai saber….

  26. fabioafc
    30/01/2013 às 9:40

    Olá, eu fiz todos os passos e obtive 100% de sucesso, selecionei apenas o meu usuario para ter acesso a internet e funcionou perfeitamente, porem, agora não consigo mais acessar o painel de controle do Endian, tanto pelo meu usuário ou qualquer outro… o que fazer?

    • 30/01/2013 às 13:44

      Deixe a estação que está usando DESMARCADA para nao usar proxy

      • fabioafc
        30/01/2013 às 15:55

        Sim, mais eu nem consigo entrar no painel de controle, ai nao consigo alterar nada!

  27. Kleber Ponce
    11/10/2015 às 21:36

    Olá, segui todos os passos.
    no console o ping está ok para o ip do servidor ad, para o nome, e para o domínio porém na hora de ingressar no AD apresenta o seguinte erro: Failed to join domain: failed to lookup DC info for domain ‘ponce.local’ over rpc: NT_STATUS_CONNECTION_RESET.
    Algém saberia me dizer o que há?
    Estou utilizando a versão 3.0.5, mas ja testei com outra versão e rolou a mesma coisa

  1. 28/01/2011 às 9:00
  2. 28/01/2011 às 9:01
  3. 28/01/2011 às 9:03
  4. 30/01/2011 às 17:43
  5. 30/01/2011 às 17:44
  6. 31/01/2011 às 9:55
  7. 01/02/2011 às 7:52
  8. 23/03/2011 às 9:39
  9. 25/03/2011 às 12:01
  10. 05/05/2012 às 19:50

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s